SAP Returning Incorrect Messages During Transaction File Run
Process Runner DB might reflect incorrect SAP returned messages while running Transaction file.
Cause
Incorrect SAP returned messages while running Transaction files are experienced due to improper transaction settings. This error usually occurs when TX Messages option at Connector for SAP is disabled at the required SAP System which is selected to login. Another reason for such consequence is lack of any one Authorization from the function group as mentioned in the table below.
| Function Group Authorization | Description |
|---|---|
| SDTX | If user has SDTX function group authorization, then Method 1 is selected in Standard TX Setting. |
| SIGE | If user has SIGE function group authorization, then Method 2 is selected in Standard TX Setting. |
| BATG | If user has BATG function group authorization, then Method 3 is selected in Standard TX Setting. |
Note: If user has BATG function group authorization, then Method 3 is selected in Standard TX Setting.
Solution
Enable TX Messages Option at Connector for SAP
Following are the generic steps to enable TX Messages option for selected SAP system in the Connector for SAP window.
- Open Process Runner DB and open the transaction file in which such problem persists.
- Select SAP Shortcut option and select the required SAP System.
- Select Properties and switch to Transaction Settings tab.
- Make sure that TX Messages option in Standard TX Setting is enabled.
Check whether required function group authorization is assigned to user or not
Following steps can help you to check if required function group authorization is assigned to a user or not:
- Logon to SAP using GUI into SAP system where authorization problem seems to occur.
- Run transaction code SE37 and type in AUTHORITY_CHECK_RFC, click single test (F8).
- In USER ID field, enter user name who has accessing problem or for whom the authorization is to be checked.
- In FUNCTION GROUP field, enter RFC_NAME required (For e.g. SDTX, RFC1, BATG).
- Select execute (F8).
If this results in an exception then user does not have appropriate authorization. Security team will have to add appropriate authorization as per instruction provided.