Error During Process Runner Start-up
During the Process Runner startup, an error message similar to the following appears
Cannot create folder: C\Users\innsrt01\Documents\Innowera
Cause
This error typically occurs when a user launches Process Runner during installation on a Citrix server—before the application is published. When this happens, the application saves path and configuration settings to the Windows registry. These settings are then notified to all Citrix users. If the path is already set, Process Runner uses the existing value instead of determining a new one.
Solution
You can resolve this issue using one of the following two methods:
Method 1: Delete Registry Entries for Each Affected User
Use this method if only a few users are affected. You’ll need to log in to the Citrix server with each user’s credentials and manually delete their Process Runner registry entries.
To delete the registry entries,
- Select the Start button and enter REGEDIT in the search box to open Registry Editor.
- Go to HKEY_CURRENT_USER > Software > Innowera> Process Runner.
- Delete the Process Runner folder.
Method 2: Use a Configuration File to Reset Settings for All Users
Use this method to apply registry settings across all users by distributing a configuration file.
To create and distribute the configuration file,
Open a text editor (such as Notepad).
-
Copy and paste the following registry keys:
ForceKey = INNOWERAPATH,EXCELPATH,V2_LICENSEPATH,GUIEXECUTIONPATH,LICFILELOADPATH,ONLINESAMPLEDOWNLOADFOLDER,TEMPPATH,PROCESSPATH [HKEY_CURRENT_USER\Software\Innowera\Process Runner\Options] "INNOWERAPATH"="" "EXCELPATH"="" "V2_LICENSEPATH"="" "GUIEXECUTIONPATH"="" "LICFILELOADPATH"="" "ONLINESAMPLEDOWNLOADFOLDER"="" "TEMPPATH"="" "PROCESSPATH"=""
Enter the path to be pushed for the keys within double quotes.
Save the file as ProRSetting.icf.
-
Copy the ProRSetting.icf file to the application folder at
C:\Program Files\Innowera\Process Runnerto apply the settings for multiple users in your organization.If Process Runner is installed on a 64-bit version of Windows, use the following path instead:
C:\Program Files (x86)\Innowera\Process Runner
Direct users to restart Process Runner and verify the application launches without errors.