Skip to main content

Troubleshooting Errors

Issue with License Expiration Date

Symptom: In the IEWF Configuration Tool, the About dialog displays wrong license Expiration Date for cloud license.

Solution

Perform the following steps:

  1. From the start menu, open IEWF Configuration Tool.
  2. Select Help > Process Runner Cloud Information. The Process Runner Cloud Information window appears.
  3. Select Reset and confirm to restart the application.
  4. Go to C:\ProgramData\Innowera\Innowera Easy Workflow Service\ISW_ProR_Cloud_ESWRK and delete all the files in the folder.
  5. From the start menu, open IEWF Configuration Tool again.
  6. Select Help > Process Runner Cloud Information. The Process Runner Cloud Information window appears.
  7. Enter the Organization Name, Email Id, Configuration Key and select Save.
  8. Confirm to restart the service and User Authentication window.
  9. When all services in the Easy WorkFlow Service Status screen are started, go to Help > About to verify the updated Expiration Date.

Issue with Easy Workflow Service

Symptom:

In the Miscellaneous Settings window of Easy Workflow Cockpit, you may see a message similar to the following.

Primary Service version “2.3.1.0” might be stopped on server “TEST123”. Last status as on 16-08-2018 14:30:21.

Cause:

This error is displayed if one of the following conditions is true:

  • The service is not running.
  • The Easy Workflow database that the service is pointing to is not correct.
  • The service was stopped from the database configuration tool.

Solution

Perform the following steps:

  1. Restart the service in the Easy Workflow Service Status window.
  2. If the issue is not resolved, then uninstall the Easy Workflow service and install the service again. Ensure that this service points to the correct Easy Workflow database.

Unable to Connect to SQL Server Database

Symptom:

In several cases of installation for SQL Server, TCP/IP is disabled by default. In such a scenario, an error message is displayed when trying to connect to the Easy Workflow database created on the SQL Server.

Solution:

User from sysadmin security group of SQL Server must enable the TCP/IP Protocol through the Configuration Manager.

To enable connection with SQL Server through TCP/IP Protocol,

  1. From Start menu, go to SQL Server Configuration Manager.
  2. In the left pane, expand SQL Server Network Configuration, and select Protocols for MSSQLSERVER.
  3. Right-click Protocols for MSSQLSERVER. The pane on the right side lists the connection protocols that are available.
  4. if TCP/IP status is Disabled, right-click TCP/IP and select Enable.
  5. Restart the database service. TCP/IP is enabled.

Excel Launch Issue in Non-Interactive User Mode

Error MSG: Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80080005 Server execution failed (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE))

Solution:

  1. Add the user who must be configured to run the Easy Workflow service with full permission.

    Permission_4

  2. To give full permission to the user, type DCOMCNFG.exe in the Run dialog box and press Enter. The Component Services window is displayed.
  3. Expand Component Services > Computers > My Computer > select DCOM Config.
  4. Right-click Microsoft Excel Application in the pane on the right side, and then select Properties.

    Permission_2

  5. Switch to Security tab, select Customize under Launch and Activation Permissions, and select Edit.
  6. Select the user who must be configured to run the Easy Workflow service and give full access as shown in the following screenshot.

    Permission_6

  7. Select Customize under Access Permissions, and select Edit.
  8. Select the user who must be configured to run the Easy Workflow service and give full access as shown in the following screenshot.

    Permission_7

  9. Select Customize under Configuration Permissions, and select Edit.
  10. Select the user configured to run the the Easy Workflow service and give full access as shown in the following screenshot.

    Permission_8

  11. Note: If the Easy Workflow service is installed on multiple servers, then you must perform the same procedure on all the servers.

Was this article helpful?

We're sorry to hear that.